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Digitizing 
 

GIS map layers come in many forms and are available from a wide range of sources including 

public agencies and private firms. Even though a large amount of spatial data currently exists, it 

is common in mapping for a cartographer to create “from scratch” base maps to be used in 

mapping and GIS analysis. Digitizing data involves tracing over pre-existing maps or 

photographs using a digitizing tablet (for hard-copy maps and photos) or onscreen (for digital 

maps and photos). In this exercise you will use the onscreen or “heads-up” method in ArcGIS 

Pro in which you will trace over an aerial photograph. 

 

When creating map layers for GIS, it is important that they are able to align with existing 

geographically referenced, or georeferenced, data. In this exercise, the photograph you are using 

is already georeferenced. If it were not, you would need to align it in its proper geographical 

context—a process called georeferencing. You will not do georeferencing in this exercise. 

 

In this exercise, you will: 

✓ Create map layers 

✓ Create a spatial bookmark 

✓ Use the Edit toolbar 

✓ Draw map features 

✓ Modify symbol properties 

✓ Create a map layout 

✓ Create a Legend using the Legend 

Wizard 

✓ Insert a scale bar and north arrow 

 

Step 1: Opening the Project 

 

• Start ArcGIS Pro. You will open an ArcGIS Pro file: Lab6_Digitizing.aprx. 

 

• Once the map loads, you will see an air photo of a neighborhood in southeast Macomb, 

Illinois. 

 

You will create new map layers and draw them based upon the air photo. As you progress 

through the lab, you will zoom in and out frequently. You will create a spatial bookmark and call 

it “Mapping Area” exists so you can return to the same view as when you opened the project file.  

 
 

 

A bookmark identifies a particular spatial extent of the map that you can save and return 

to. You may return to your bookmarked location by clicking View >Bookmarks. A GIS 

project in ArcGIS Pro can have multiple bookmarks. To create a bookmark, fill the Data 

View with the desired geographical extent and got to Map >Bookmarks >New. 

 

Introduction to Cartographic Processes 
Geography (GEOG 3305) 

Lab 6: Digitizing 
 



 

2 

 

• Take a few moments to move around the photograph. Zoom in, zoom out, pan around. When 

you are done, right-click on the image layer in the Table of Contents, go to Zoom to Layer, 

then click Map >Bookmarks >New Bookmark. Name the new bookmark “Mapping Area” 

so that you can return to the extent of the photograph as you work through this lab.  

 

When you create items during this part of the exercise, you will want to be zoomed in much 

more than the extent of the spatial bookmark. You will need to zoom in even further to get 

maximum detail and then zoom back out. 

 

When creating base maps for use in GIS software, create a separate file (layer) for each of the 

feature types that you will place on the map. For example, make city blocks one layer and 

structures another. Similarly, rivers would be one layer while lakes another. On the other hand, 

different types of the same feature are put in a single layer. By having multiple layers, you can 

easily turn features on and off and reorder them in the Table of Contents. In the photograph, you 

may have noticed there are a handful of feature types that you can digitize: city streets, city 

blocks, structures (houses, garages, etc.), a creek, and vegetation (trees, bushes, etc.). 

 

In city infrastructure mapping, there are two common ways that city streets are represented. The 

first, and most common, is to draw city streets as lines. In this method, the line is drawn down 

the center of the street. Information such as the street name, address ranges, street width, and 

surface type can be included in the attribute table. The second method, common in land use 

mapping, is to draw the blocks as polygons. In a city where there are hundreds or thousands of 

blocks, the empty space between the blocks represents the streets. While many maps use one or 

both of these methods, you will do the latter for this exercise. 

 

Step 2: Creating Shapefiles 

 

In order to draw the features, you must first create new feature classes for your map. To do this, 

you will utilize the Catalog pane.  

 
 

 

The Catalog pane does what its name implies: it allows you to build a catalog of your 

geographic data. Through your catalog, you can manage and access your geographic data 

stored in folders that you connect to. Within your connected folders, you can browse your 

data as well as examine its associated attribute tables and metadata. You can also create 

new data and insert it into an ArcGIS Pro project by dragging the file to the Table of 

Contents.  

 

• Go to View - Catalog pane. Browse to Folders - then the folder where you saved your lab 

data. Right-click on the geodatabase, then go to New – Feature Class.  
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Figure 1. Create a new feature class in the catalog pane 

• A dialog box appears where you can set several characteristics of your new feature class. 

 

• First, name the feature class Blocks and make the Feature Type Polygon. Do not click 

OK yet. 
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Figure 2. Use this interface to  

define the feature class properties. 

The photo in the project has a spatial reference assigned to it. Because you are going to be 

adding data layers on top of the photo, it is best to set the spatial reference for your new feature 

class to match the photo. 

 

• The photo uses the NAD 1983 Transverse Mercator coordinate system. As you are 

creating the new feature class, it will adopt that coordinate system (Figure 3).  
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Figure 3. Spatial Reference for new feature class. 

 

• Press Finish. You now have a new, projected feature class called “Blocks.” Note: the 

new feature class is not automatically added to your map. You created it in the lab6 

geodatabase, but did not add it to the map yet. You will create three additional feature 

classes and then add them all to your map.  

 

• Now create: 

• Another polygon feature class called Structures 

• A line feature class called Streams. 

• A point feature class called Trees. 
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Figure 4. Newly created feature class 

 

• Add the feature classes you just created using the Map - Add Data button.  

• Arrange the layers in the Table of Contents so the Blocks layer is below the other layers 

by dragging the layer name downwards. 

 

 
Figure 5. Order of layers in table of contents.  
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Step 3: Digitizing the blocks 

 

• You will begin by adding polygons to the Blocks feature class. Go to the Edit tab – then 

Create. Choose Blocks, then the polygon (create a polygon feature).  

 

 

Figure 6. Create features (block polygons). 

• Now start drawing your block polygons. 

 

• Zoom in so you can see the edge of a block in greater detail. Be careful not to zoom in so 

far that it becomes difficult to make out the block edges. 

 

• Now, start clicking around the edge of the block (do not go down the middle of the 

street) and double-click to finish the polygon. See example of the first finished block in 

Figure 7.  
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Figure 7. Example of first digitized block.  

• When you are drawing polygons or lines, click once to start the feature. Move your 

mouse around the edge of the block, clicking once to add additional vertices. 

 
 

 

The more you are zoomed in, the more accurate your polygon will be so zoom in to a 

point that you can see only part of the block. A handy feature in the editing mode is that 

if you need to see beyond the visible area of the photo (i.e., you need to scroll up or 

down, left or right) you can click the scrolling arrows and still be able to add vertexes to 

the polygon you are creating. Be careful not to scroll too far in any direction as you want 

to be able to see the last vertex you drew. 

 

If you are using a mouse with a scroll wheel, you do not need to use the scroll arrows to 

pan the image. Simply depress the scroll wheel and move the mouse to pan the image. 

You can also use the scroll wheel to zoom in (roll the wheel down—towards you) or 

zoom out (roll the wheel up—away from you). 

 

• Double-clicking (or pressing the F2 key) will finish the feature you are drawing and 

close the polygon.  

• Click around the edge of the block to add vertices. For portions of blocks that extend 

beyond the photograph, use the edge of the photo as the de facto edge of the block. When 

you get back to your starting vertex, double-click or press the F2 key to finish the 

polygon. 
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A completed polygon will display the symbol properties (fill color and outline color) shown in 

the Table of Contents. The most recently completed feature will also be selected—noted by the 

cyan outline. Clearing the selection (Selection >Clear Selected Features) will remove the cyan 

highlighting. 

 

For sides of blocks that are curved rather than straight lines, which is most of the blocks, make 

sure that your line follows the curve. You will want to have enough vertices so that the block 

edge does not have obvious and sharp changes in direction. You also need to make sure that you 

do not have too many vertices as this situation can produce block edges that seem to have several 

small undulations. It may take some practice to produce the sweeping curves of some of the 

blocks. You may wish to use the various arc or curve drawing tools (Error! Reference source 

not found.) for curved features. 

 

When you are sketching, you can zoom in and out, pan, and switch between sketching tools 

without finishing the feature. This capability is very useful for blocks with straight segments but 

rounded corners. In cities it is rare for a city block have a corner that is a sharp 90° angle. 

 

• To make editing a bit less cluttered, click once on the Blocks legend (the colored box 

below the layer name) in the Table of Contents. Doing so will open the Symbol Selector 

window. 

 

• Select the hollow box (note the preview window in the upper right-hand corner of the 

window—this will show you what the polygon will look like as you change attributes). 

Also, change the Outline Width thickness to 1.5 (click in the window and type 1.5) and 

using the drop-down arrow, change the Outline Color to a red (it will show up better 

against the dark grays of the air photo than the default grey border color). Press OK. 

 

Your final map will be displayed without the photo. It is a good idea to occasionally turn off the 

photo in the Table of Contents to see what your map looks like. You may discover that some 

map features look good with the photo as a background but not as good without it. 

 



 

10 

 

 
Figure 8. Example of digitized blocks with no fill color and red outline.  

 

If you wish to make changes to a polygon, use the Modify tool. On the Edit tab, click on Modify, 

then a side menu will open with various options. If you are not happy with a feature, you can 

either delete the feature and draw it again, or modify it (by editing the vertices).  
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Figure 9. The Modify tool. Use this tool  

to modify or move selected features. 

 

Step 4: Digitizing the houses (structures) 
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Next you will draw polygons that conform to the houses.  

 

• On the Edit – Create features screen, switch the target to the Structures feature class. 

 

• Follow the procedure you used to draw the blocks, try as best as possible to draw your 

polygon around each house.  

 

When drawing structures, you want the shape you are drawing to conform to the “footprint” of 

the house. With aerial photographs, it is very difficult, if not impossible, to see a building 

footprint. You can see the roof, however.  

 

• Use the roofline to serve as a surrogate for drawing the footprints of structures (the 

presence of eaves on houses means that roofs are usually slightly larger than the building 

footprint—don’t worry about this discrepancy at this time). Digitize around the edge of 

the roof. 

 

Because the photo is taken at an angle slightly off from vertical, most of the rooftops are not 

directly over the footprint (base) of the structure. After you have finished a polygon, move it so it 

conforms to the location at the base of the building. The easiest way to do this is to locate a 

corner at the base of the house and then move your polygon so the corresponding corner is in this 

location. You may be forced to use your best judgment about where some of “footprints” are 

exactly. Because this is only an exercise to teach you the techniques, don’t worry if you don’t 

have it exactly right. 

 

Be careful to have 90° angles for your roofs! It is easy, especially when zoomed in, to follow the 

pitch of the roof when digitizing. Digitize from corner to corner of the roof—be careful not to 

accidentally digitize from corner, to roof peak, and then back to the other corner. It’s a good idea 

to view your house polygons without the photo to see if you have drawn them with straight 

edges. Try your best on this part, but it’s okay if it’s not perfect.  

 

Step 5: Digitizing the stream 

 

 

• When you are done drawing the structures, you will draw the creek that flows through the 

middle of the photo. Switch to the Target to Streams before drawing the creek 

 

• Remember, the Streams layer is a line, not a polygon layer. Draw a single line down the 

middle of the creek (do not go down one edge and come back on the other). The creek 

does traverse the width of the photo. In places where it is obscured by trees (like at the 

west edge of the photo), use your best judgment about the stream location. 

 

• Double-click (or press F2) at the end of the stream length to complete the line. 

 

Step 6: Digitizing the trees 

 

Finally, you will digitize locations for trees. 
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• Switch the Target to Trees. As this is a point layer, you will need to click just one time to 

create a feature. 

 

• Digitize the base of each tree (as best as you can see). Do not digitize shrubs, bushes or 

hedgerows. Again, try your best. It’s difficult to see every single tree.  

 

 
 

 

You probably noticed that there were several instances where it was very difficult to 

determine a block edge, roof edge, base of tree, etc. because of limitations in the 

photograph. In most cases, these limitations can be overcome by having increased 

familiarity with the specific features being digitized—oftentimes accomplished by field-

checking. 

 

• You will print the layout WITHOUT the air photo. Turn it off in the table of contents. 

 

• After you have turned off the photo, evaluate how all your map features look. Because you 

will be printing the map without the photo, you need to make sure that the map looks good 

without it.  

✓ Make sure no elements go beyond borders (e.g., don’t have buildings extending into the 

street or past the edge of the photo). 

✓ Make sure the streets look reasonable—don’t have varying widths of the streets within a 

block and try to keep them uniform along the street length. 

✓ If you need to adjust any feature, go back into edit mode and make the adjustments.  

 

Step 7: Symbolyzing the features 

 

• Color your layers using the Symbol Selector (click on the layer’s legend in Table of 

Contents)  

 

✓ Blocks layer: Make the fill color Sahara Sand and the outline 1.0 thick and black 

✓ Structures layer: the structures Suglight Sky (the light blue at the top of the third column 

from the right in the color palette—put your mouse over the color to reveal its name) with 

a Gray 70% border.  

✓ Streams layer: Choose the River symbol and make the width 3.0. 

✓ Trees layer: Choose the Circle 2 symbol. Make it 4.00 points with a Spruce Green fill 

color. 
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Figure 10. Map after digitizing and symbolizing. Your map may be slightly different.  

Step 8: Creating a Map Layout to Print 

 

Now we’ll create a draft map layout. 

 

• First, turn off the photograph by deselecting its check box in the Table of Contents. 

• Also, turn off the basemap layer.  

 

• Zoom to the Mapping Area spatial (Map >Bookmarks >Mapping Area). 

 

• Create a new layout. Go to Insert – New Layout. Add Guides (right-click on ruler, Add 

guides, then specify Both, the Offset at Edges (for Placement) and 0.5 inches for Position. 

Add an additional guide. Right-click on ruler, then go to Add guide. Click on the top 

ruler at 2.5 inches from the left page corner and add a guide there. Click on Insert – Map 

Frame and then choose the map you have created. Draw a rectangle from the left guide 

(at 2.5 inches) to the right guide.  

 

You will now see your map and layers displayed in a page with the map positioned to the right of 

center (Figure 11). 

 



 

15 

 

 
 

Figure 11. The map in the Layout View. 

 

Prior to exporting, you will add a few more elements. 

 

• Add Guides again (right-click on ruler, Add guides, then specify Both, the Offset at 

Edges (for Placement) and this time 0.25 inches for Position. Insert a neatline around 

the entire map layout (Insert >Rectangle). Draw the rectangle from the 2.5 guide to the 

.25 mark on the other page edges. This is how you create a rectangle at even distances 

from three sides (and the bigger distance on the left side where we will place the map 

elements).  

 

• Add the following map title (Insert >Rectangle Text): Digitizing in ArcGIS Pro on the 

map. Change the font to Arial, the size to 24 and the style to bold. Click OK. 

 

• Place the title in the space to the left of the mapped area inside the margin. Move the 

title so the top of the lettering is roughly flush with the top of the mapped area. 
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• Using Insert >Text, put the cartographer’s information in the bottom left-hand corner 

of the map inside and close to the neatline (left-justified, 10 point, Arial): 

 

Your name 

Today’s date 

Projection Text 

 

• Add a scale bar (Insert >Scale Bar). Next, add a north arrow (Insert >North Arrow). 

Place the north arrow above the scale bar. 

 

• Finally, you will add a legend. Insert >Legend. Place the legend between the title and the 

north arrow. Change the font of the layernames to Arial, 18 pt.  

If you have large empty areas in the space between the title and cartographer’s information, you 

may need to move the scale bar, north arrow and/or legend so that these items are evenly 

distributed within the available space. 

 

To create a PNG file (for digital submissions): 

 

• Export the map by selecting Share >Export Layout … 

 

• Change the Save as type: to PNG. The Resolution should be 300 dpi. Save the png file 

to your Lab6 folder and name it YourLastName_Lab6.png. Then submit it to the 

assignment dropbox in D2L.  

 

NOTE: When you close ArGIS Pro, if it prompts you to save your edits, say Yes.  



 

17 

 

 
Figure 12. The final map exported as a png file. 

 



 

18 

 

•  


